Montar imagen raw de máquina virtual virtualbox para kvm

He tenido que cacharrear estos días con una máquina virtual de VirtualBox que estaba en otra máquina y trabajar con ella en mi portatil y como VirtualBox no me va mucho y me está dando muchos problemas con losd módulo del kernel, he decidido pasar la máquina virtual a kvm.

Lo primero ha sido convertir la imagen de formato .vdi a .raw:
[shell]qemu-img convert -O raw imagen-virtual-box.vdi imagen-kvm.raw[/shell]
En principio con esto me hubiera valido… pero algún tipo de cosa ha pasado con los uuids de los discos y tampoco he tenido mucho tiempo para repararlo, así que mi plan era editar la configuración del grub a pelo. Para ello tenía que o bien usar un cd de arranque en la máquina virtual o montar el disco y tocar sin tanto rollo… así que he decidido el camino largo, el de montar el disco, pero que para mí es más cómodo.

Para montar la imagen lo vamos a hacer usando el dispositivo especial loopback

# buscamos el positivo loop libre
[shell]# losetup -f
/dev/loop0[/shell]
montamos el disco de la maquina virtual
[shell]losetup /dev/loop0 imagen-kvm.raw[/shell]
verificamos el montaje
[shell]#losetup -a
/dev/loop0: [fe01]:14778412 (/home/jorge/imagen-kvm.raw)[/shell]

Para ver las particiones que contiene usamos fdisk :
[shell]
#fdisk -l /dev/loop0

Disk /dev/loop0: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00043519

Device Boot Start End Blocks Id System
/dev/loop0p1 1 1044 8377344 82 Linux swap / Solaris
/dev/loop0p2 * 1044 5222 33564672 83 Linux
[/shell]

agregar particiones al mapper
[shell]#kpartx -a /dev/loop0[/shell]
Verificamos las particiones
[shell]#kpartx -l /dev/loop0
loop0p1 : 0 16754688 /dev/loop0 2048
loop0p2 : 0 67129344 /dev/loop0 16756736[/shell]
y montamos la particion que queremos
[shell]mount /dev/mapper/loop0p2 /mnt/vm[/shell]
verficamos que está montada
[shell]# mount
/dev/mapper/debian-root on / type ext3 (rw,errors=remount-ro,user_xattr)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/sda1 on /boot type ext2 (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/mapper/loop0p2 on /mnt/vm type ext4 (rw)[/shell]He tenido que cacharrear estos días con una máquina virtual de VirtualBox que estaba en otra máquina y trabajar con ella en mi portatil y como VirtualBox no me va mucho y me está dando muchos problemas con losd módulo del kernel, he decidido pasar la máquina virtual a kvm.

Lo primero ha sido convertir la imagen de formato .vdi a .raw

Fallo grave de seguridad en Plesk mod_php

Nos llega información acerda de una fallo de seguridad en Plesk:

“SECURITY ADVISORY:
Parallels Plesk Panel 9.x, 10.x, 11.x – Privilege Escalation Vulnerability

Parallels Customer,

Please read this message in its entirety and take the recommended actions.

Situation

Parallels Plesk Panel privilege escalation vulnerabilities have been
discovered and are described in VU#310500 and CVE-2013-0132,
CVE-2013-0133 (CVSS score 4.4 –
http://www.kb.cert.org/vuls/id/310500).

Impact

This impacts Parallels Plesk Panel for Linux versions 9.x, 10.x, 11.x.

You are at risk if you have Apache web server running mod_php,
mod_perl, mod_python, etc.

You are NOT at risk if you have Apache web server running Fast CGI
(PHP, perl, python, etc.) or CGI (PHP, perl, python, etc.).

Solution

Parallels has issued security updates for Parallels Plesk Panel
versions 9.x-11.x. The security updates for Parallels Plesk Panel 11.x
and Parallels Plesk Panel 10.4.4 will automatically appear inside your
Parallels Plesk Panel control panel – please apply them as soon as
possible.

The security hotfix for Parallels Plesk 9.x is available for download
here: http://kb.parallels.com/115942.

Workaround

Parallels understands that it’s not always practical for immediate
upgrades, so we have provided a solution to fix this vulnerability.
For the immediate solution, customers should read this knowledge base
article for instructions: http://kb.parallels.com/115942.”

Recordamos que para instalar los microupdates de plesk se pueden ejecutar estos comandos :

/usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component base
/usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components

Cómo configurar dyndns.org en Comtrend 5813 FTTH

A diferencia de otros routers hay un pequeño detalle, bueno dos, necesarios para que funcione la configuración de dyndns.org en el router Comtrend que proporciona telefónica con la instalación de fibra óptica.

[shell]
hostname: tunombredehost.dyndns.org
interface: pppoe_eth0.6/ppp_0.6
user: username ( no es el email )
password: tu password
[/shell]