Parallels Plesk Panel 10.4 Marketing Preview

Parallels anuncia su nueva release para el 18 de Noviembre. Seguramente ya es conocido por todos los lectores qué es Parallels Plesk Panels, para los que no, que sepais que Plesk es software de gestión de hosting que permite gestionar dominios, cuentas de correo, cuentas ftp, certificados, ssl e integrarlo con otras aplicaciones de Parallels. Aquí teneis más informacion http://www.parallels.com/products/plesk/

¿ qué tienes que hacer para probalarla ? fácil, puedes encontrarla aquí http://www.parallels.com/download/plesk10.4

Resumiendo las mejoras importantes:
* Configuración de php.ini por dominio
* Configuración de módulos de apache: activar y desactivar módulos
* Dedicar una ip de salida a un cliente para enviar correo
* Descargar ficheros de log vía ftp
* Buzones de correo no aceptan nuevos mails si han superado la quota de espacio
* Mejoras en el sistema de backup ( siempre ha sido un punto débil de Plesk menos en la versión 8 )
* Mejoras en las herramientas de migración ( otra herramienta delicada que no siempre funciona bien )

Esto es lo más destacable, pero para ver la lista completa podeis pasaros por estos enlaces :

* Parallels Plesk Panel 10.4 for Linux-based Operating Systems release notes
* Parallels Plesk Panel 10.4 for Windows-based Operating Systems release notes

Drivers nvidia en Debian Wheezy y Xorg con dos monitores ( dual head )

Desde el que instalé Debian Lenny en el portatil del trabajo he tenido bastantes cuelgues. Al final no te pones en serio a mirar la causa por dos razones, una por que es esporádica y la otra por que siempre hay un montón de cosas que hacer, así que reinicio y me resigno ( like a windows user :'( ). Pero como estaba ya bastante harto, hace dos días pasé mi máquina del trabajo a estable a testing.

Todo fué bastante bien, como siempre con apt-get es bastante quitando un incidente con los módulos de perl que ya comenté en este enlace http://www.senin.org//2011/10/18/pasando-de-squeeze-a-wheezy/ . Todo aparemente como siempre, actualizas, reinicias… se me olvidó bajar los últimos drivers de nvidia ( que han vuelto a cambiar la web ) y a buscar los drivers again and again. Instalo los drivers y cuando arranco… algo pasa… por mucha monitorización que exista, mucho nagios y cacti… al final la observación diaría es el mejor método para saber que algo pasa en tus máquinas. La mía tardaba en abrir gedit más de 30 segundos y subía la cpu a tope … empecé a acordarme de las leyes de murphy….

Novelas a parte, hay un problema con los drivers de nvidia, tanto los de la web como los compilados non-free, ni idea del motivo, pero después de un par de horas probando entre “nouveau“, “nv”, “vesa” y “nvidia” al final conseguí que funcionaran los “nouveau“. El driver “nv” parece que ya está obsoleto y no está en el kernel, el nvidia me iba a pedales y el vesa vale para salir del paso pero poco más.
Si alguno de vosotros se encuentra en la misma situación de driver nvidia instalado en el sistema y quereis cargar “nouveau” os saldrá algo como esto : “[drm] failed to open device”

Después de haber leyendo la documentación oficial, y echarle otro rato revisando el sistema … encontré que en /etc/modprobe.d/ existen varios ficheros de nvidia que hacen que meten en blacklist al driver nouveau y deshabilitan el drm… así que me los cargo y listo, ya rula “nouveau”. Además aproveché para reconfigurar la consola con “dpkg-reconfigure console-setup” y dejar el tipo de letra como indica el kernel. A su vez , encontré que en /etc/default/grub puedes añadir el tamaño de letra y resolución por defecto de la consola con esto :
[shell]# /etc/default/grub
GRUB_GFXMODE=1024×768
GRUB_GFXPAYLOAD_LINUX=”1024x768x32″[/shell]
y ya tengo mi consola con la letra cani como a mí me gusta

Para acabar, en el curro tengo un monitor grande conectado al portatil y al no usar nvidia , la configuración de nvidia ya no funcionaba, así que me puse a buscar como hacer de mi monitor

http://en.gentoo-wiki.com/wiki/X.Org/Dual_Monitors La gente de Gentoo siempre han sido muy prolífica en cuanto a documentación, pero parece que están un poco paraetes.

Resumo rápdio que es un tostón ….

Con “xrandr -q” vemos las salidas de video , los modos que soporta y si están o no activos. Esta es mi configuración con el monitor conectado a la salida vga:
[shell]$ xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
LVDS-1 connected (normal left inverted right x axis y axis)
1280×800 60.0 +
1024×768 59.9
800×600 59.9
640×480 59.4
720×400 59.6
640×400 60.0
VGA-1 connected 1280×1024+0+0 (normal left inverted right x axis y axis) 380mm x 300mm
1280×1024 60.0*+
1280×960 60.0
1024×768 60.0
800×600 60.3
640×480 60.0
720×400 70.1
HDMI-1 disconnected (normal left inverted right x axis y axis)[/shell]
Esto hace que el monitor VGA esté a la izquierda del escritorio LVDS ( Low Voltage Differential Signalling output (typically a laptop LCD panel) http://www.x.org/archive/X11R7.5/doc/man/man4/intel.4.html#toc7 )
Posteriormente le digo que el monitor VGA es mi pantalla principal, para que aparezcan los paneles, iconos y demás. Finalmente desactivo la pantalla del monitor.
[shell]xrandr –output VGA-1 –left-of LVDS-1
xrandr –output VGA-1 –primary
xrandr –output LVDS-1 –off[/shell]
Para que las horas que me he tirado poniendo mi máquina en marcha, no se pierdan en vano, comparto mi experiencia con vosotros. Espero que os sirva.

UPDATE1 :
Se me olvidaba comentar que mientras escribía esto se me volvió a tostar… jefe, si me lees, cómprame un portátil nuevo porfis 😀

UPDATE2 :
Otra cosa que peta al actualizar es gnome-settings-daemon concretamente la version 2.30.2-4 y lo hace así en ~/.xsession-errors
[shell]
(gnome-settings-daemon:4693): libnotify-WARNING **: you must call notify_init() before showing ** libnotify:ERROR:notification.c:568:notify_notification_show: code should not be reached
[/shell]

Por lo que leí, para salir del paso rula bien con la versión anterior, así que me la bajé de http://snapshot.debian.org y la he dejado como bloqueada “hold” en el sistema por ahora
[shell]
wget http://snapshot.debian.org/archive/debian/20110409T155325Z/pool/main/g/gnome-settings-daemon/gnome-settings-daemon_2.30.2-3_i386.deb
dpkg -i gnome-settings-daemon_2.30.2-3_i386.deb
aptitude hold gnome-settings-daemon
[/shell]

Pasando de Squeeze a Wheezy

Es raro que pasen estas cosas, pero pasan
[shell]Can’t locate File/Copy.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/bin/defoma-app line 7.[/shell]
No es capaz de seguir la instalación por que no está en el sistema el modulo Copy.pm de perl ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494106 )
[shell]dpkg –install /var/cache/apt/archives/perl-base_*.deb
apt-get install -f[/shell]
y a tirar palante

Zaapa 2832U fc2850

Hace unos meses me compré en Mediamarkt un ‘DVB USB DONGLE’, lo que se viene llamando ‘un pincho pa ver la tele en el ordena’ de la marca Zaapa ( ZTDVBTUSB ). El caso es que el modulo del kernel para linux rula solo con la version 2.6.3x y no estaba funcionando para la version 3.x. Quería asegurarme que funcionara al menos en
Windows y le pedía gente que usa windows que lo probara, por el tema de la garantía más que nada 😀

Pues resultó que con el cd que venía el pincho, no rulaba con ninguna versión de windows ni bajando de la web oficial el driver, así que estaba un poco mosqueao ya. Hoy he hecho una última intentona identificando directamente el hardware que lleva :
[shell]
FCI 2580 9CBM
RTL 2832 U 9CE76S1 GA04D
[/shell]

y buscando en linuxtv.org ,y concretamente en este enlace : http://linuxtv.org/wiki/index.php/DVB-T_USB_Devices veo lo siguiente :

[shell]
MSI DIGIVOX mini II V3.0 (RTL2832 version) also. DigiVox mini deluxe
Realtek RTL2832U, FCI FC2580
[/shell]

Uuuuuuuuuuu esto tiene una pinta muy rica…. así que decidí buscar los drivers en la web de MSI… es triste y común encontrarse con que grandes compañías pasan de los usuarios y como es el caso no existe ni la ficha de producto ni driver para descargar ni nada de nada. Despuésssss de mucho tiempo buscando y buscando encontré esto :

La url del producto en msi pero en Alemania
[shell]
<a href=”http://www.msi-computer.de/product/mm/DigiVox-mini-Deluxe.html” target=”_blank”>http://www.msi-computer.de/product/mm/DigiVox-mini-Deluxe.html</a>
<a href=”http://www.msi-computer.de/service/download/driver-1000067.html” target=”_blank”>http://www.msi-computer.de/service/download/driver-1000067.html</a>
DigiVox_Mini_Deluxe_64.1.1028.2009.zip
[/shell]

Este driver funciona para Zaapa, al menos lo detecta en Windows y escanea canales, lo demás se está probando en este momento ….

[debian] xulrunner

Otro error actualizando Debian esta mañana.

Al actualizar el sistema y abrir Iceweasel…. cataplas !!!!!

Error de lectura XML: entidad no definida
Ubicación: jar:file:///usr/lib/xulrunner-7.0/omni.jar!/chrome/toolkit/content/global/netError.xhtml
Número de línea 338, columna 43:        <h1 id="et_corruptedContentError">&corruptedContentError.title;</h1>
------------------------------------------^

Así que lo de siempre, googlear y encuentro un bug reportado en http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=643862

Hacen referencia a que es causa de un paquete e idiomas que no está actualizado, así que para evitar estar dando vueltas, directamente los desinstalo y otro día… ya veremos 😀

  iceweasel-l10n-es-ar* iceweasel-l10n-es-es*

y a funcionar….

Symantec cambia la imagen del sello Verisign

Symantec está enviado un aviso a todos sus clientes informando que a partir de abril de 2012 el sello de ‘VeriSign Trust’ pasará a ser ‘Norton Secured by Verisign Trust’.
Este cambio se justifica por un estudio que han realizado en el cual los clientes tienen una mayor confianza en el sello VeriSign si aparece la palabra Norton. Tampoco se detalla mucho el estudio realizado.

En resumen en abril del mes que viene empezaremos a ver un nuevo icono VeriSign. Este cambio es transparente para los usuarios finales ya que el sello se muestra usando un fragmento de javascript.

Aquí el comunicado completo :

“Hace ya más de un año que Symantec adquirió los servicios de identidad y autenticación de VeriSign. Desde entonces, hemos incorporado novedades que mejoran de forma patente los certificados SSL, aunque nuestros planes van más allá y pronto le sorprenderemos con otras.

Más funciones.
Para hacerle la vida aún más fácil, ahora le ofrecemos nuevas funciones y recursos:
las funciones optativas Express Renewal y AutoPay/AutoRedeem;
* el estudio de vulnerabilidad para certificados SSL;
* el nuevo Centro de información sobre certificados para grandes empresas.
*
La misma protección. Mejor asistencia.
En Symantec, nos esforzamos por ofrecerle productos cada vez más ventajosos con las señas de identidad de VeriSign: una seguridad óptima y procesos de autenticación de empresas y sitios web de eficacia demostrada. De ahora en adelante, seguirá disfrutando del mismo servicio de atención al cliente y del mismo personal de ventas, pero con una atención aún mejor.

Planes de futuro.
Hemos analizado la percepción de la marca de comprobación y la imagen de marca asociada, y los resultados indican que nuestro sello merece una opinión aún mejor a los internautas (en relación con otras marcas de confianza) cuando la marca de comprobación aparece combinada con el nombre de VeriSign y la marca Norton de Symantec. De hecho, el sello Norton™ Secured es más reconocible que otras marcas de confianza para el 77 % de los consumidores.* Así pues, a partir de abril de 2012, todos los sellos VeriSign Trust darán paso al sello Norton™ Secured, powered by VeriSign. El reemplazo se realizará de forma automática, así que no tiene que preocuparse por nada. Se trata de la misma marca de comprobación de siempre, pero con pequeños cambios que le darán más visibilidad y aumentarán el número de impresiones.

Estamos a su servicio.
Queremos que se sienta plenamente satisfecho con el servicio que le ofrecemos y que esté al tanto de las novedades. Si tiene alguna duda, no dude en ponerse en contacto con su gestor de cuentas.

Un cordial saludo,

Fran Rosch
Vicepresidente de servicios de confianza
Grupo de seguridad de la información de Symantec “

comandos que fallan con sudo por no encontrar el path

En los últimos días me estaba encontrando en una de las máquinas con que al ejecutar comandos con sudo me fallaban algunos scripts como apt-get o algún otro comando que seguro que estaba en el sistema. Es más, entrando con “su -” se ejecutaba correctamente sin tener que especificar el path.

El caso que más me molestaba era el ejecutar un upgrade y encontrarme esto :

[shell]
sudo apt-get dist-upgrade
….
dpkg: warning: ‘ldconfig’ not found in PATH or not executable.
dpkg: warning: ‘start-stop-daemon’ not found in PATH or not executable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root’s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)
[/shell]

Como a veces pasa, le he hecho la vista gorda… hasta que me he cansado 😀

La solución, fijo que está en el fichero de /etc/sudoers y ahí he agregado lo siguiente :
[shell]
Defaults env_reset
Defaults secure_path=”/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin”
[/shell]

todo solucionado 😀